2008 Forenza Transmission - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-19-2015, 04:03 PM   #1 (permalink)
Newbie
 
Join Date: Feb 2015
Location: Tucson AZ and San Diego CA
Posts: 1
Gallery: 0
SteveSAZ is on a distinguished road
Question 2008 Forenza Transmission

I see much discussion about transmission problems with 2007 and earlier Forenzas, but not too much about 2008s.

Recently, when starting from stopped, my 2008 Forenza (~52K miles) has started to slip out of drive into (what appears to be) neutral for just a moment, then smoothly goes back into drive. It may do this once or twice each time I drive it. No CEL comes on or appears at any time, so it can't be diagnosed, according to the service people I've spoken with.

BTW, I can sidestep the problem by putting the transmission into 3rd when starting from stopped, then put the car into drive once I get moving. However, that doesn't ease my mind about possible impending doom.

I don't want to find myself suddenly stranded in the middle of nowhere, so I'd like any thoughts about what is going on here, and what my options are, so that I can nip this in the bud. Thanks!
SteveSAZ is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-25-2015, 03:31 PM   #2 (permalink)
Member
 
Join Date: Feb 2015
Posts: 70
Gallery: 0
Waiter21 is on a distinguished road
Default

Transmission range sensor. about $60 from dealer. About $20 from e-bay. (HUM - I may order a spare).

I replaced mine at about 60k miles. car wouldn't shift. I think it threw a code (P0705 I think).

make sure the engine is cool when you replace it.

The sensor is plastic and the metal spline shaft will damage the plastic spline if its hot. not hard to replace

I thought I had a photo. Its on the drivers side bolted on the top of the tranny, look down between the power stearing fluid bottle and the EGR valve.

Here is a video link.

http://youtu.be/IZ3AM9SzA-A

Last edited by Waiter21; 02-25-2015 at 03:41 PM.
Waiter21 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:38 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.