***Having a huge problem***PLEASE HELP US - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-10-2015, 08:21 PM   #1 (permalink)
Newbie
 
Join Date: Feb 2015
Posts: 1
Gallery: 0
Jnksdaddy is on a distinguished road
Default ***Having a huge problem***PLEASE HELP US

My fiancee and i tried swapping out our old head unit, and now my passenger side tail light and fog light do not work along with my radio and interior lights? Please help, can't afford a ticket for the tail light being out... PLEASE HELP.......2005 Suzuki Forenza : sad:
Jnksdaddy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-11-2015, 02:44 PM   #2 (permalink)
Full Member
 
Join Date: Jan 2011
Location: PR, USA
Posts: 149
Gallery: 0
P1NkY is on a distinguished road
Default

First check fuse #28 (10A) in the engine compartment, if it is good...
You have an open ground (G203)
It is behind and to the right of the head unit.
Ground screw G203 is loose or missing or black wire is cut.
It normally connects to position 5 of the red splice pack (S203) to the left of the head unit.
Refer to the diagram for G203 and S203:

Good luck and hope it helps.

Last edited by P1NkY; 02-11-2015 at 02:47 PM.
P1NkY is offline   Reply With Quote Quick reply to this message
Old 02-27-2015, 03:03 PM   #3 (permalink)
Veteran
 
Join Date: Feb 2007
Location: ny
Posts: 3,098
Gallery: 11
7-even is on a distinguished road
Default

theres a ton of wires behind the radio. check all your fuses. make sure you didn't forget to reconnect anything. make sure the hazard switch is plugged back in, if not the tail lights wont work. let us know what happens
7-even is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:41 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.