HELP!!! 2007 Forenza- Turn Signals&Dash Lights - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-22-2014, 08:50 AM   #1 (permalink)
Newbie
 
Join Date: Sep 2014
Posts: 1
Gallery: 0
kristuhhh is on a distinguished road
Unhappy HELP!!! 2007 Forenza- Turn Signals&Dash Lights

I just bought a 2007 Suzuki Forenza for super cheap. It had been hit in the front end. I replaced all of the parts and am now driving it. I have 2 problems with the car.

1. The turn signals and the hazards are not working. They do not work on the instrument cluster as well as both front and back flashers. I have replaced the fuses, changed the switch its self and changed the relays up under the drivers dash! Still no turn signals or hazards! Not sure if this is a combination problem or 2 different problems.


2. The air bag light, battery light, C/E light, power steering light, & brake lights are all illuminated on the dash. I have ran codes on the car many times. I always get ONLY ONE code P0113. (IAT sensor). Trying to figure out why all of those lights are on. Was told by the person I bought it from that it was a ground wire that needed fixed..?


I only have 700$ tied up in this car. It runs and drives fine but I do not have signals or hazards and all of those lights are on and i dont know what else to do..PLEASE HELP!!! Thanks!
kristuhhh is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-01-2014, 03:46 PM   #2 (permalink)
Newbie
 
Join Date: Jun 2008
Location: Ontario, CA USA
Posts: 20
Gallery: 0
DamnCampers is on a distinguished road
Default

Quote:
Originally Posted by kristuhhh View Post
1. The turn signals and the hazards are not working. They do not work on the instrument cluster as well as both front and back flashers. I have replaced the fuses, changed the switch its self and changed the relays up under the drivers dash! Still no turn signals or hazards! Not sure if this is a combination problem or 2 different problems.
If I remember correctly there is a recall pertaining to the wiring behind the instrument cluster that might or might not affect those. I don't remember which years that the recall covers so it might be worth having it looked at to see if the recall has been completed.

Quote:
Originally Posted by kristuhhh View Post
2. The air bag light, battery light, C/E light, power steering light, & brake lights are all illuminated on the dash. I have ran codes on the car many times. I always get ONLY ONE code P0113. (IAT sensor). Trying to figure out why all of those lights are on. Was told by the person I bought it from that it was a ground wire that needed fixed..?
Ask your local auto parts store what an IAT sensor is and where it might be located. They normally won't be able to tell you where it is exactly, but knowing where to find it will help you locate it in the service manuals so that you know what you are looking for.
DamnCampers is offline   Reply With Quote Quick reply to this message
Old 10-04-2014, 07:53 PM   #3 (permalink)
Veteran
 
Join Date: Feb 2007
Location: ny
Posts: 3,098
Gallery: 11
7-even is on a distinguished road
Default

hi. first off the iat sensor is located in the intake tubing of the car. now for the other issues. the airbag light might be on because of a faulty airbag sensor inside the passenger seat, a common problem on the reno/forenza. its also possible you have a bad power steering modual, ssps i think they call it. as for the brake lights first check and make sure theyre all working and none are out.if you changed fuses and such then youll have to start checking wiring. there is a recal on the splice pack behind the gauge cluster but i dont think that goes to your year, not sure. honestly what i would do is call the person you bought the car from and find out excactly what ground is loose or bad. save yourself hours and hours, or lots of cash if a mechanic has to look, trying to track it down.
7-even is offline   Reply With Quote Quick reply to this message
 
Old 10-04-2014, 09:02 PM   #4 (permalink)
Veteran
 
Join Date: Sep 2014
Location: New Zealand
Posts: 3,465
Gallery: 0
2013GV is on a distinguished road
Default

most common grounds to cause these issues are the main one by the fuse box on the drivers side panel, and the ones up by the lights. Check the ones under the hood, since its had a collision, chances are theres a ground missing in the front of the car. Check the one near the relay / fuse box under the hood too.
I'd get the lighyts going first and you might just find the IAT fault may go as well, bad grounds can cause all sorts of crazy issues.
__________________
2015 5 dr Grand Vitara 2.4 (daily driver)
1971 V8 HG Holden with 383 stroker 9" torq lok and TH350 trans (the toy)
Mitzi RVR 2.0 (not one of my better buys)
the 2013 3 dr GV is now the off road only toy

"Dogs feel very strongly that they should always go with you in the car, in case the need should arise for them to bark violently at nothing right in your ear."
2013GV is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:30 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.