Airbag Light Flashing - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Equator
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-27-2018, 04:31 PM   #1 (permalink)
Newbie
 
Join Date: Nov 2017
Posts: 6
Gallery: 0
no1tmorrow is on a distinguished road
Default Airbag Light Flashing

I have a 2009 Equator that when someone sits in the front passenger seat the Airbag light in the center of the dash. I go through the reset process with the key on/off on/off etc. and it clears. Anyone have any idea on what I can try to fix this issue?

Thanks
Thom
no1tmorrow is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-27-2018, 04:35 PM   #2 (permalink)
Newbie
 
Join Date: Nov 2017
Posts: 6
Gallery: 0
no1tmorrow is on a distinguished road
Default

Wow.. .Proofread..... the airbag light in the center of the dash starts to flash and never shuts off.
Quote:
Originally Posted by no1tmorrow View Post
I have a 2009 Equator that when someone sits in the front passenger seat the Airbag light in the center of the dash. I go through the reset process with the key on/off on/off etc. and it clears. Anyone have any idea on what I can try to fix this issue?

Thanks
Thom
no1tmorrow is offline   Reply With Quote Quick reply to this message
Old 05-29-2018, 07:07 PM   #3 (permalink)
Newbie
 
Join Date: Nov 2017
Posts: 6
Gallery: 0
no1tmorrow is on a distinguished road
Default

Don't know if this site is even active anymore but I am still having random flashing issues that have to be reset about 1 out of 4 times someone sits in the passenger seat. Figured out the reset with the key on off wait 5 seconds repeat technique.
no1tmorrow is offline   Reply With Quote Quick reply to this message
 
Old 07-13-2018, 05:43 PM   #4 (permalink)
Veteran
 
Join Date: Sep 2014
Location: New Zealand
Posts: 3,918
Gallery: 0
2013GV is on a distinguished road
Default

sounds like a faulty pressure sensor in the seat cushion
__________________
2015 5 dr Grand Vitara 2.4 (daily driver)
2008 Swift M15A
1971 V8 HG Holden with 383 stroker 9" torq lok and TH350 trans (the toy)
Mitzi RVR 2.0 (not one of my better buys)
the 2013 3 dr GV is now the off road only toy

"Dogs feel very strongly that they should always go with you in the car, in case the need should arise for them to bark violently at nothing right in your ear."
2013GV is offline   Reply With Quote Quick reply to this message
Old 07-14-2018, 10:27 AM   #5 (permalink)
Veteran
 
Donewrken's Avatar
 
Join Date: Jul 2017
Location: Tehachapi California
Posts: 1,251
Gallery: 1
Donewrken is on a distinguished road
Default

Welcome to the forum!

I'd suggest lighter passengers.


Best of luck

Don



.
__________________
I'm here in the USA.
1994 Geo Tracker 1.6L 8V TBI, 3-spd auto 4WD 152K timing belt/wp power windows Camo seat covers carpet Dashcam & backup cam
1999 Chevy Tracker removable hardtop 1.6L 16 valve 5-speed 4WD 104K timing belt/wp aluminum radiator electric fan Bartact seat covers Vixen airhorn onboard compressor Dashcam rear locker winch
2002 Grand Vitara 2.5L 4WD 123K Valves lifters rings/bearings timing chain gears tensioners WP coils ECU
1991 GMC K2500 4WD 454 Xcab
1997 Trans Am LT1 auto
Donewrken is offline   Reply With Quote Quick reply to this message
Old 09-18-2018, 10:23 PM   #6 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,146
Gallery: 0
aquanaut20 is on a distinguished road
Default

Quote:
Originally Posted by no1tmorrow View Post
I have a 2009 Equator that when someone sits in the front passenger seat the Airbag light in the center of the dash. I go through the reset process with the key on/off on/off etc. and it clears. Anyone have any idea on what I can try to fix this issue?

Thanks
Thom
The only correct way to diagnose this issue is with a scope, it involves working on the LAN..

Caution! the SES circuits can be explosive..

Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Equator

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:14 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.