car stalls at idle after battery change - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-18-2013, 12:51 AM   #1 (permalink)
Sal
Newbie
 
Join Date: Aug 2013
Posts: 1
Gallery: 0
Sal is on a distinguished road
Exclamation car stalls at idle after battery change

Hi, I encountered a starting problem with my alto 660cc, auto trans, 2006. this came out to be a dead battery. I changed it, now the engine starts but would stall if I do not accelerate the throttle (on neutral or parking). Same is the case if while driving if I have to stop, the engine would stall. (batt changed yesterday)

I do not know whether its problem of so called 're-learning' or some adjustment problem or while diagnosing the battery problem, I cranked it many time and engine initialization process did occur that may times, may be that has some thing to do with it,,,, any advice???
Sal is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-24-2014, 04:57 AM   #2 (permalink)
Newbie
 
Join Date: Jun 2014
Posts: 2
Gallery: 0
royoung1 is on a distinguished road
Default

have you checked the charging system? does the idle need adjusting? maybe your ignition timing needs re adjusting, also maybe an idea to get a garage to check for any fault codes in the ecu in case of any sensor failure causing it to cut out.
royoung1 is offline   Reply With Quote Quick reply to this message
Old 06-24-2014, 07:59 AM   #3 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,942
Gallery: 0
fordem will become famous soon enough
Default

It's not unusual for EFI systems to need to "re-learn" the engine's operating parameters, and it's possible to have the engine stall during the process - I wouldn't adjust anything immediately - but if it continues to stall after a day or so, I would get it checked.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:01 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.