Disappointed with my Suzuki Alto SZ4 - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-14-2013, 03:39 AM   #1 (permalink)
Newbie
 
Join Date: Mar 2013
Posts: 1
Gallery: 0
DivaB74 is on a distinguished road
Thumbs down Disappointed with my Suzuki Alto SZ4

I traded in my fiat panda for Suzuki Alto SZ4 09 plate - and in the month I have had it, have regretted my decision.

Getting used to the 3 cylinders and the noise has taken time..but after only 4 weeks, the rear washer water is flooding into the drivers footwell (seems a few have this problem) every time I accelerate , change into certain gear or stop it sounds as if the engine is moving about...not quite a squeak and tried to describe it to dealer, so am assuming it could be the dreaded engine mount problem?

I am also having fuel problem. Being a 1l I was expecting to use less fuel than my 1.2L Panda - boy was I wrong. Barely managing 39mpg urban driving and 41mpg motorway. My Panda got more mpg than this rubbish. The dealer says no problem, but its going back in today as I am not happy. This car will not last the length of the finance period and am considering telling them to take it back. It was not cheap and I am beginning to think I got a lemon of a car....its leaving a sour taste in my mouth just mentioning Suzuki.

Definitely will not be recommending Suzuki and will never purchase another one..now to try and get rid of this one - does anyone else regret their decision or have the same problems?
DivaB74 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-25-2013, 03:07 AM   #2 (permalink)
Newbie
 
Join Date: Sep 2012
Posts: 3
Gallery: 0
Xtenzion is on a distinguished road
Default

Hi!

The leaking windscreen liquid seem to be a fairly common fault, but the dealer is suppose to fix this free of charge during your warranty. Be happy that it did break before you run out of warranty

The engine mount problem seem to be more common in colder climates, and it seem to get worse during the winter.

About the fuel economy, it will improve with time, after I put 4000 miles on the engine I noticed better fuel economy, the engine were also smoother to run on lower revs as well. The engine is pretty horrible when it's new, but believe me it will get better with time, my engine is still improving, will be intresting to see how it's going to run once i hot 10.000miles+.

I started up with the same fuel economy as you (around 40-41mpg), and now i get 44-45 mpg (driving around town subtropical climate with aircon off). Haven't been doing much highway driving yet. If i run the aircon on, the fuel economy is just horrible...

The thing is with this engine, you have to keep your revs low to get a good fuel economy. I usualy keep them between 1.500 - 2.500, sometimes i push it up to 3000rpm if i switch straight from 3rd gear to 5th.
Xtenzion is offline   Reply With Quote Quick reply to this message
Old 05-13-2013, 04:52 PM   #3 (permalink)
Newbie
 
Join Date: Oct 2008
Posts: 1
Gallery: 0
nismohks is on a distinguished road
Default

Hi I live in the UK and I just bought a new 2013 Suzuki Alto, literally picked it up last Tuesday. I have done one tankful of mostly town and mixed driving (no highway) and got 53mpg.

Divab74 i reckon your car needs a servicing (tune up). check tyre pressures too
nismohks is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:38 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.