1983 Alto Fx starter switchmal-function - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-13-2011, 06:13 AM   #1 (permalink)
Newbie
 
Join Date: Apr 2011
Posts: 4
Gallery: 0
jonel is on a distinguished road
Default 1983 Alto Fx starter switchmal-function

My wife's 1983 Alto FX auto, only 21500 miles, is usually trouble free but a couple of days ago having driven to a destination a mile away she later found on returning to the car that the engine would start but not keep running. It was now night time.

I was called and realised that the engine would continue to run only if the starter/ignition key was held fully forward. I was not happy to do this for any time thinking I was liable to burn-out the starter motor and/or the bendix mechanism or what-ever disengages the starter drive ordinarily when the starter key is realeased when the motor fires.

I also realised that the instrument panel was not lighting up and neither was the heater fan mechanism working.

All other eletrical circuits are working, I have cheched all the fuses. There is plenty of fuel and the pump is working. Everything is normal other than the ability to keep running when the ignition key is released against it's spring-loaded (start-up) action.

I have studied the wiring chart in the owners manual but cannot really come to any conclusion for further investigation.

From the wiring chart and fuse detail I note there is one cicuit labelled "Optional" which is shown as having "W" (white) wiring. Tracing this route as best I can it seems to run to the instrunent panel, the heater fan and the ignition switch but perhaps I am reading it wrongly and/or hoping too much that I have found a potential cause. Even if I have I do not know what to do next.

ANY ONE ABLE TO POINT ME IN THE RIGHT DIRECTION.

i WOULD DRIVE IT TO THE NEAREST AGENTABOUT 12 MILES AWAY BUT COULD ONLY DO THIS HOLDING THE IGNITION KEY FULLY ON AND AS I FEAR DAMAGE THIS WAY APART FROM BEING A DANGER DRIVING SO i AM STUCK.
jonel is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:30 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.