Alto horn not working - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-20-2019, 10:33 AM   #1 (permalink)
Newbie
 
Join Date: Jul 2019
Posts: 2
Gallery: 0
briang is on a distinguished road
Default Alto horn not working

I have a 2009 Suzuki Alto which I have had from new. The horn has stopped working. The fuse is OK because it also protects the hazard warning lights which are working. I changed the horn but it still does not work. I took it to a garage who said they could not find a fault but suggested I take it to an auto electrical specialist. Before I do this, which will probably be expensive, can anyone suggest where the fault may possibly lie.
Thanks
briang is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-20-2019, 01:53 PM   #2 (permalink)
Veteran
 
Join Date: Sep 2014
Location: New Zealand
Posts: 3,677
Gallery: 0
2013GV is on a distinguished road
Default

break out the multimeter, it could be the horn button, relay, corroded wiring or other wiring issues somewhere.

Don't just throw parts at it, diagnose it properly.

do you have volts at the horn wire with button pressed? work back from there until you find the issue. Can e something as simple as a bad connection, like not cleaning paint off the horn bracket so it has a decent earth.
__________________
2015 5 dr Grand Vitara 2.4 (daily driver)
1971 V8 HG Holden with 383 stroker 9" torq lok and TH350 trans (the toy)
Mitzi RVR 2.0 (not one of my better buys)
the 2013 3 dr GV is now the off road only toy

"Dogs feel very strongly that they should always go with you in the car, in case the need should arise for them to bark violently at nothing right in your ear."
2013GV is offline   Reply With Quote Quick reply to this message
Old 07-21-2019, 04:05 PM   #3 (permalink)
Newbie
 
Join Date: Jul 2019
Posts: 2
Gallery: 0
briang is on a distinguished road
Default Alto Horn

Thanks for your suggestions. Will let you know how I get on.
briang is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:37 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.