3 brake lights dont work. - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-10-2019, 09:08 AM   #1 (permalink)
Newbie
 
Join Date: May 2019
Posts: 1
Gallery: 0
orimori is on a distinguished road
Default 3 brake lights dont work.

on suzuki alto 2013 i have checked the lighs the they are fine. also checked fuses and only st sig dont work
what is st sig fuse? and what could be the problem?
orimori is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-10-2019, 02:00 PM   #2 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,942
Gallery: 0
fordem will become famous soon enough
Default

There are a couple of questions I have found myself asking frequently of late, so here we go again ...

What is your experience troubleshooting electrical issues? Do you have a test meter and do you know how to use one?

St sig is usually starter signal, and is not usually fused - it is normally used to let the ECU know when the starter is active, and is unlikely to be related to your issue.

Back to your problem - check for voltage at the lamp sockets when the brake is depressed, if there is none, check at the brake light switch which is usually located near the top of the brake pedal, if there is none there, look for a fuse labelled stop/horn or something similar.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki Alto Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front wipers will work...then not work...then work sillyboy Interiors & Exteriors 3 06-16-2014 02:39 PM
gauge lights dont work 30geotracker Suzuki Sidekick, Escudo, Vitara, Geo, X-90 & Tracker Forum (1989-1998) 14 12-13-2011 07:15 PM
Will a bad combination switch assembly cause head lights and brake lights to not work tsaico Suzuki Sidekick, Escudo, Vitara, Geo, X-90 & Tracker Forum (1989-1998) 5 07-08-2010 10:10 AM
Reversing Lights dont Work goldauto Suzuki Esteem & Baleno Forum 0 08-01-2007 02:51 AM
guagues dont work jst854 General Car Audio, Video and Electronics 5 04-06-2007 12:14 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:48 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.