battery keeps discharging - Page 3 - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Aerio & Liana Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-06-2012, 07:57 AM   #21 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,948
Gallery: 0
fordem will become famous soon enough
Default

Some of the newer Suzukis do have an ECU controlled alternator and if your is one of these, my guess is you would have mentioned it previously - when I asked about the alternator plug and suggested there were two or three wires in the harness, you only mentioned two - an ECU controlled alternator would have had more.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-07-2012, 07:59 PM   #22 (permalink)
Newbie
 
Join Date: Jun 2012
Posts: 22
Gallery: 0
poncepr64 is on a distinguished road
Default

Hello,
I don't have the one with the ecu. I was reading on different sites and wanted to know what you thought.
My plug only has two wires.

UPDATE:
Alright...I'm back.
I took the alternator back off and took it to another auto parts store and had it retested.( I did do all you suggested, and it seemed to all point toward the alternator).

The alternator failed the voltage test, so...go a new alternator and already re-installed it.
Everything is working fine.

Thanks for all the help and suggestions, everything you said was right on the money!!!
poncepr64 is offline   Reply With Quote Quick reply to this message
Old 07-07-2012, 08:22 PM   #23 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,948
Gallery: 0
fordem will become famous soon enough
Default

Glad to hear you're on the road again - no Suzuki ever deserves to be parked -
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is offline   Reply With Quote Quick reply to this message
 
Old 07-07-2012, 10:14 PM   #24 (permalink)
Max
Moderator
 
Max's Avatar
 
Join Date: Aug 2006
Location: South Carolina, USA
Posts: 17,335
Gallery: 0
Max will become famous soon enough
Default

Woo hoo!

(told ya')

Glad that you got it sorted.
__________________
'99 Grand Vitara JLX, 2.5L V-6, 4WD, 5 spd std, '00 "Limited" leather interior
'72 Nova. SB, TH-350, PB, PS, A/C.
Max is offline   Reply With Quote Quick reply to this message
Old 07-07-2012, 10:24 PM   #25 (permalink)
Newbie
 
Join Date: Jul 2012
Location: Puerto Rico
Posts: 13
Gallery: 0
mrmorales21 is on a distinguished road
Default

I knew it was the alternator. It happened to me with two different cars but im glad you finally have it working like it should be
mrmorales21 is offline   Reply With Quote Quick reply to this message
Old 12-23-2014, 12:04 AM   #26 (permalink)
Newbie
 
Join Date: Dec 2014
Posts: 2
Gallery: 0
Nacho Mnz is on a distinguished road
Default

Awesome thread, I'm trying to find out what happened to my friend's car and you pinpointed several possible issues . Tks
Nacho Mnz is offline   Reply With Quote Quick reply to this message
Old 12-07-2015, 09:29 AM   #27 (permalink)
Newbie
 
Join Date: Jun 2008
Posts: 7
Gallery: 0
riceboy1701e is on a distinguished road
Talking 2000 Vitara Battery/Charging Problems

All:

Many thanks for the replies and advice here! I'm having similar problems with my wife's Vitara. Battery discharged, tested, found to be bad. Was replaced with a NAPA batt...same problem: discharged. At the mechanic now...I have a suspicion that the alternator is bad, but there is/was no indicator light on the dashboard (the +/- battery light), *except* for about 1/2 second just before I turned the ignition off. Last time this happened, the mechanic tested the alternator, said that it was good. Now I'm wondering...bad relay? Bad wiring? Loose/disconnected wire?

I'll hope for the best. Again, my thanks! I'll keep checking here on the forums for responses from you folks!
riceboy1701e is offline   Reply With Quote Quick reply to this message
Old 12-08-2015, 09:32 AM   #28 (permalink)
Newbie
 
Join Date: Jun 2008
Posts: 7
Gallery: 0
riceboy1701e is on a distinguished road
Default

Yep! Alternator!
riceboy1701e is offline   Reply With Quote Quick reply to this message
Old 06-19-2019, 05:32 PM   #29 (permalink)
Newbie
 
Join Date: Jun 2019
Posts: 2
Gallery: 0
DSMRedSuzuki is on a distinguished road
Default 2003 Suzuki Aerio SX Won't Start

Hello everybody. I accidentally cross-jumped my 2003 Suzuki Aerio SX, and now the car won't start. We ran this by a mechanic, and he told us these cars have an auto shut off if accidentally cross-jumped. Does anybody how we can reset the battery? Thank you so much for your help!
DSMRedSuzuki is offline   Reply With Quote Quick reply to this message
Old 06-19-2019, 05:39 PM   #30 (permalink)
Newbie
 
Join Date: Jun 2019
Posts: 2
Gallery: 0
DSMRedSuzuki is on a distinguished road
Default 2003 Suzuki Aerio SX Won't Start

Hello everybody. I accidentally cross-jumped my 2003 Suzuki Aerio SX, and now the car won't start. We ran this by a mechanic, and he told us these cars have an auto shut off if accidentally cross-jumped.


The fuses are checked, everything is good, and there is NOTHING happening when the ignition is turned on. The battery is also fully charged and in good condition. Does anybody how we can reset the battery? Thank you so much for your help!
DSMRedSuzuki is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Aerio & Liana Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:38 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.