Suzuki Swift 1.5 GLS Power Steering Issue - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Technical > Suspension, Wheels and Tires
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-13-2017, 01:17 PM   #1 (permalink)
Newbie
 
Join Date: Dec 2017
Posts: 1
Gallery: 0
elmagodeoz is on a distinguished road
Default Suzuki Swift 1.5 GLS Power Steering Issue

Hello,

I own a 2010 Suzuki Swift 1.5 and I'm having issues with the Power Steering since a couple days ago.

I was driving last Friday on the highway at 110 kph and since it was foggy I turned on the fog lights. When I pushed the button, the lights turned on but the EPS light on the dashboard turned on too:

Click image for larger version

Name:	luz testigo swift eps.png
Views:	7
Size:	16.1 KB
ID:	85497

At the same time, obviously, the wheel was hard as hell as if the car didn't had any power steering. I pulled over and turned the engine off and back on after a minute or so. The EPS light was off, but it turned on again as soon as I moved the wheel.

I had to drive all the weekend in that condition, and last Monday I went to a workshop so they could scan it. All they found was a "C1142" failure. He tried to erase the failure but his computer didn't seem to be working properly.
I went the next day to another workshop and the same happened (same issue code and same weird functioning of the pc-scanner). They suggested me to go to an official Suzuki workshop as soon as I can and I will do that, but I'd love to know first if any of you had this same issue and how you managed to solve it.

To summarise, this is the chronology:
  • Friday Morning: Changed the tyre pressure to 32 PSI each. (my tyres are 185/60R15)
  • Friday Night: I drove about 30 km and then the EPS light came on after I turned on the fog lights. The wheel became very hard to move, specially at low velocity.
  • Saturday Morning: I changed the battery since it was having major issues and delivering incorrect voltage. The EPS light continued to appear as soon as I moved the wheel.


I read many forums and some people got it fixed after they changed the battery, some of them said it was a wrong tyre pressure. I could be having both here, or maybe the steering engine is already damaged because of the old battery.


I'd appreciate any suggestions on this matter



Thanks and regards
elmagodeoz is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-13-2017, 04:36 PM   #2 (permalink)
Veteran
 
Darrell.'s Avatar
 
Join Date: Jun 2014
Location: UK
Posts: 4,931
Gallery: 0
Darrell. is on a distinguished road
Default

Welcome to the forum.
I also remember reading low battery voltage causing fault codes with the power steering and maybe just the extra load of the fog-lights made it dip too low. Here is what the 2007 workshop manual has to say on that code. Under the code clearance it only showed using the Suzuki scan tool, it may be a case of generic code readers not being able to clear this.

__________________
2005 Grand Vitara MT 1600se.
Darrell. is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Technical > Suspension, Wheels and Tires

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:38 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.