Suzuki Forums banner

Search results

1-4 of 4 Results
Advanced Search
  1. Looking for help with a puzzling 4WD engagement problem

    2G (1999-2005) Vitara & Grand Vitara
    Mystery Solved Thanks for all your inputs, newbie to this forum but I frequent others for my other vehicles. The response here is solid. So I'm definitely up for some kind of dipstick award. I was doing great from the start using my own experience and this forum. The pump was not running...
  2. Looking for help with a puzzling 4WD engagement problem

    2G (1999-2005) Vitara & Grand Vitara
    2003 Vitara 2.0 2dr. Most of the problems I have encountered have been lack of use. I wonder if this low use car was ever in 4x4. The runs briefly and shuts off as if the pressure has been obtained. 5 psi is the max that I have measured from the pump. The puzzle to me is when I put on shop air...
  3. Looking for help with a puzzling 4WD engagement problem

    2G (1999-2005) Vitara & Grand Vitara
    I have viewed and followed the excellent description and photo's regarding the pump. I went from having a pump that was not running to one that illuminated the 4x4 light and engaged the diff. Forward a few weeks and I am pulling a small bush out in our yard (on loose gravel) and only one rear...
  4. New to forum but not to Tracker

    New Member Area/Introduction
    Hi, Recently purchased what is my 3rd go round with one of these great cars. Previously owned a 95 Sunrunner, followed by a 03 4Dr V6 with full load of options including leather. Happy to be back to basics with garage kept 03 Tracker LX shorty with only 105k KM's. Thought it was time to jump...
1-4 of 4 Results
Top