1.6l idles too high when cold any help - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Technical > Performance
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-19-2009, 02:11 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2009
Posts: 1
Gallery: 0
botiklr is on a distinguished road
Default 1.6l idles too high when cold any help

i have just bought a 1987 suzuki samurai with a 1.6 geo tracker motor in it. it has the complete wirinh harness from trailtough for the conversion and complete new exhaust including o2 sensor and cats. my problem is when it starts up it idles high(around 3000 rpms) . after the temp comes up and warms up it comes down to 800 rpm. any help on this please email me. [email protected]
thanks alot
Doug
botiklr is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-26-2009, 05:21 AM   #2 (permalink)
Member
 
Join Date: Nov 2008
Posts: 32
Gallery: 0
thommy is on a distinguished road
Default

isn't that just the auto choke working? :S
__________________
:D
thommy is offline   Reply With Quote Quick reply to this message
Old 10-14-2009, 02:45 PM   #3 (permalink)
Member
 
Join Date: Oct 2009
Location: california
Posts: 38
Gallery: 0
tonyvallevista2 is on a distinguished road
Exclamation high rpm

sounds like an incorrect temp rated or faulty coolant temp sensor:
tonyvallevista2 is offline   Reply With Quote Quick reply to this message
 
Old 10-16-2009, 03:57 AM   #4 (permalink)
Newbie
 
Join Date: Oct 2009
Posts: 2
Gallery: 0
kaylavictoriaa is on a distinguished road
Exclamation Hi

This is interesting ,, thanks for sharing ....

_____________________

Please contact me

[email protected]
[email protected]
[email protected]
[email protected]
[email protected]
kaylavictoriaa is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Technical > Performance

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:53 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.