Grand vitara turbo blown - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Technical > Performance
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-08-2014, 04:37 AM   #1 (permalink)
Newbie
 
Join Date: Dec 2014
Posts: 1
Gallery: 0
Jonner is on a distinguished road
Default Grand vitara turbo blown

Hi new here. My names alf.
I have a wee question if I may be so bold.
I have owned a suzuki grand vitara 1.9 ddis since 2007.
Recently there's been a catalogue of different problems.
Glo plugs, intercooler, water pump pulley. And now the turbo has blown.
Finding a replacement was a challenge in itself.
However settlers on a rebuild.
On driving home some 50 miles from home. A wee puff then lost power. No torque at all.
Sort of knew the turbo had blown.
Phoned out breakdown only to find out my other car is the only one covered on the policy. Rant later
I called my mate who said o could drive it home if I take my time and drive slowly.
The turbo had started whining really bad. It the stopped and went quiet.
Still no torque thou.
On turning on a round about I noticed the revs had sort of stuck around 2500 rpm. On changing gear I noticed black smoke coming out. I pulled over and stopped the engine. It didn't stop. Even with the ignition turned off.
Suddenly I remembered a conversation about a year previous with another friend about a works car that was running in its own oil or the like.
I managed to stop the engine and pay for tow truck to take me home.
New turbo is now fitted and awaiting the intercooler to be cleaned out.
My engine still stops and starts but is still smoking.
Maybe get better after intercooler is cleaned.
Is there anything else that needs checking out prior to running her to see if there's engine damage.
Regards alf
Jonner is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Technical > Performance

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:05 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.