Suzuki Forums: Suzuki Forum Site - Reply to Topic
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum > popping/clicking in drivetrain under load??
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Thread: popping/clicking in drivetrain under load?? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-22-2011 01:40 PM
KJ2837 I will check my joints again and I do have a brass sheet..Its laying on my work bench,lol.Been there for months! I just havent had the time....Seems to be my life story now days!!lol
08-19-2011 12:51 AM
VaderSS I'd check the joints first.


As for popping out of 4wd, have you replaced the shifter sheet?
08-19-2011 12:36 AM
VaderSS I'd check them. Easy enough, just slide under and give the shaft a twist while holding both yokes in your other hand. There should be no play.
08-19-2011 12:30 AM
KJ2837 Think it could be the joint or maybe the input shaft? ive heard this could also be the problem if worn? I noticed last winter my 4WD popping out if I did bungie it in place...
08-19-2011 12:27 AM
KJ2837 NO,USED ORIELLY'S. BUT ITS ONLY BEEN A FEW MONTHS? LIKE MAYBE 3? Oh,my caps were on,im not yelling..lol just too tired to go back to change it....
08-18-2011 11:25 PM
VaderSS Did you use Suzuki U-Joints? Anything else is going to wear out quick.
08-18-2011 02:18 PM
KJ2837
popping/clicking in drivetrain under load??

Not too long ago (few months ago)I replaced all but the 2 front U-joints.About a month ago I started hearing a popping or clicking noise that sound like is coming from maybe my middle shaft.I hear it on take off,under load and sometimes changing gears? any ideas???

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:24 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.