Suzuki Forums: Suzuki Forum Site - Reply to Topic
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Technical > Performance > Low compression on fresh engine
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Thread: Low compression on fresh engine Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-12-2010 10:27 AM
heartyharhar Your description sounds exactly like the things I ran into and the stuff I read. The wide ring gap is indicative of the bore being wider than it is supposed to be. The ring manufacturers normally get it pretty close for the advertised bore size, so if the gap is big, the bore is probably too big. I also found the tolerances on this engine for bore to piston size are much tighter than other engines, which machine shops might not check and thus be more liberal than they should be with the bore size.

It is normal for the top of the piston to be a lot smaller than the skirt. The skirt to bore clearance is what counts.

Since you already tore down the engine again (I did the same thing), bring the block and pistons back to the machine shop and have them measure them which they can do easily and accurately. Have the specs handy so they can see how tight the tolerance is. It is likely they bored the block too much. Good luck.
08-12-2010 09:02 AM
irvinelmo Hi,
I did my first rebuild on an 89 1.6L Sidekick and have compression problems. I bought a rebuilt head for it, and it has new .50mm over pistons and rings.

Compression is 85-89 psi on all cylinders, goes up to 135-140 on wet test. Book says 170-199 is the normal range. Engine started and ran OK, but has very little power on test drive. I tried seating the rings with accelerations and decelerations but dry compression was still the same. Didn't start a day later and I suspected it was due to the low compression. When cranking slowly with a socket and the valve cover off, I easily hear air squeezing past the rings listening down the oil passages to the crank case. I heard nothing listening at the intake and exhaust ports with manifolds off.

I checked the ring gap during assembly and it was .020-.025" (over the limit), but a note in the manual said ring gap is not critical unless .040" or more. I suspected the machine shop messed up the bore and pulled the engine and tore it down again.

I don't have a great micrometer, just a dial caliper supposedly good to .001". It shows about .001" difference between the piston skirt and bore diameters, but hard to tell if it is accurate. Book says clearance should be .0008-.0014 but this is beyond the accuracy of my caliper. One thing that surprised me was the top of the pistons were .020" smaller than the skirts.

Any suggestions? Is it normal to hear ring leakage on a freshly rebuilt engine? Is the ring gap too wide?
10-14-2009 05:19 PM
heartyharhar
Fixed

The machine shop screwed up. The bore was about 3 thousandths over the piston diameter with the service limit being about 1.6 thousandths IIRC. I had to buy another set of new pistons, .75mm over this time, and brought it to a different machine shop since this was the second time the first shop screwed up (they missed a crack in the old block). Compression is much better now. Leakdown test looks fine.
10-14-2009 02:07 PM
tonyvallevista2 some ring leakage would be normal or how could you get blow by ?

piston heads get hotter so they would need to be smaller.

You said that you replaced the head, did you do a leakdown test to be sure a valve was not leaking ?

add a little oil thru the plug hole, if psi goes up it is rings, if psi stays the same it is valves, same test for checking compression in worn engine, assuming everything else is correct.

just an idea.
06-15-2009 10:50 AM
heartyharhar
Low compression on fresh engine

I did my first rebuild on an 89 1.6L Sidekick and have compression problems. I bought a rebuilt head for it, and it has new .50mm over pistons and rings.

Compression is 85-89 psi on all cylinders, goes up to 135-140 on wet test. Book says 170-199 is the normal range. Engine started and ran OK, but has very little power on test drive. I tried seating the rings with accelerations and decelerations but dry compression was still the same. Didn't start a day later and I suspected it was due to the low compression. When cranking slowly with a socket and the valve cover off, I easily hear air squeezing past the rings listening down the oil passages to the crank case. I heard nothing listening at the intake and exhaust ports with manifolds off.

I checked the ring gap during assembly and it was .020-.025" (over the limit), but a note in the manual said ring gap is not critical unless .040" or more. I suspected the machine shop messed up the bore and pulled the engine and tore it down again.

I don't have a great micrometer, just a dial caliper supposedly good to .001". It shows about .001" difference between the piston skirt and bore diameters, but hard to tell if it is accurate. Book says clearance should be .0008-.0014 but this is beyond the accuracy of my caliper. One thing that surprised me was the top of the pistons were .020" smaller than the skirts.

Any suggestions? Is it normal to hear ring leakage on a freshly rebuilt engine? Is the ring gap too wide?

John

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:57 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.