Suzuki Forums: Suzuki Forum Site - Reply to Topic
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum > Sami mishap in the river
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Thread: Sami mishap in the river Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-28-2010 07:43 PM
wrenchwoman Thanks BillJohn. That sounds like a good idea, especially considering I do plan on taking it across the river again. Next time, however, I will take the obvious low water path, or just wait till late July when the river's way down anyway.
06-28-2010 07:10 PM
Billjohn If you think you may be playing in the water very often, consider running hoses to the diff breathers. If you run the lines up into engine compartment you can run them into the air cleaner. As long as your axle seals are ok it will save flushing the diffs after every trail.

You can also do this with the t-case and (with a little drilling and tapping) the tranny.
06-28-2010 05:35 PM
wrenchwoman
Quote:
Originally Posted by Baratacus View Post
you could do a flush, or a series of changes... it wouldn't hurt, but probably not necessary. Water is more dense than oil and it will run out the drain plug first.
You're right. I was very surprised to see that much water when I pulled the plug. I dumped the old stuff and replaced it with new oil and filter and let it run for 15 minutes. Once it cools off, I'm going to go dump that out, too, and do another filter with new oil and hopefully that should be enough.

Thanks!
06-28-2010 04:37 PM
Baratacus you could do a flush, or a series of changes... it wouldn't hurt, but probably not necessary. Water is more dense than oil and it will run out the drain plug first.
06-28-2010 12:48 PM
wrenchwoman I got the Sami home yesterday and just now changed the plugs and it fired right up. I checked the dipstick and at the bottom it does look a little carmel-ish. I'm about to change the oil and filter, but is that going to be good enough? Should I do it a couple times in a row?
06-26-2010 04:56 PM
wrenchwoman It's acting like it could be the igniter/coil. That crapped out on me a couple months ago and I already stole that off my extra Sami. But I'll definitely check fuses, never even thought of that. Thx
06-26-2010 04:35 PM
Baratacus Check and make sure you didn't blow a fuse. If you cooked the Coil/igniter fuse then you wuldn't be able to start it.
06-26-2010 04:22 PM
wrenchwoman
Sami mishap in the river

Okay, so yesterday I had my Sami in the river, only about 1 foot of water. However, in returning to the shore I came across a drop in the riverbottom which put it underwater up to the hood on the passenger side. As soon as it "fell", I cut the engine fearing I would do damage, or should I say more damage if I didn't cut the engine. Today it cranks and cranks but doesn't turn over. I did have water in the air cleaner housing, which I let dry out but still nothing. Until I get it towed home sometime tomorrow to have a look and see if I even have a spark, any ideas? Or any definite things that may have been toasted, like the ECU which was underwater.

I do not see evidence of water when I pull the dipstick out. If any, even a small amount of water did get in, is changing the oil enough if I get it running? Or should I do that first anyway, along with both the front and rear diffs and then troubleshoot? I do have a spare Sami here that I could swap parts on for testing. I guess I'm wondering if I could have fried the ECU?

I'll take any suggestions or ideas. Even sarcastic jokes. Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:41 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.