Suzuki Forums: Suzuki Forum Site - View Profile: fordem
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Members List
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
fordem will become famous soon enough

fordem fordem is offline

Moderator

Visitor Messages

Showing Visitor Messages 1 to 10 of 20
  1. mcancill
    12-26-2018 11:10 AM - permalink
    mcancill
    Hey Fordem, I was wondering if you could provide a bit more information to help me out about my suspension on my 93 Geo Tracker 4x4. I’m reading this thread where you give some great info: https://www.suzuki-forums.com/suzuki...ower-ride.html

    I’m having the same issue that my Geo is super rough. I drive both on and off road. My question is: how do I know the suspension is still doing it’s job and the rough ride is just ‘normal’ rough. The previous owner lifted this Tracker in the past slightly. How would I evaluate if the shocks should be replaced?
  2. Paula P
    07-03-2017 01:46 PM - permalink
    Paula P
    fordem, thanks for your reply reference my Flashing Heater/blower knob, my suzuki is a vitara 1.6 petrol 3dr 2007 . I'm new to this site so I'm not too sure if I've posted this correctly. ?? does this help ? the book says take to a dealer if it flashes, but that will be very expensive !! ??
  3. Brit101
    03-25-2017 11:52 AM - permalink
    Brit101
    Fordem can you change a character in my heading of a post?
    "What did you do to your Esteem/Boleno today/", it should have a question mark at the end, not a slash. Would you be so kind and change it, about four down in the Esteem forum?
  4. regwal
    02-19-2017 10:09 AM - permalink
    regwal
    Thanks Fordem. Rhinoman PMed me saying he passed my problem along to you. I could not get on site no matter what was tried. A long shot was reaching someone to help and it worked. I was going nuts. Thank you for whatever you did for it was easy to get on and reset PW.
  5. richycat
    02-10-2017 09:23 PM - permalink
    richycat
    Hi, I have a 2007 suzuki sx4 with a bad engine. Is there an engine i can use instead of the sx4 engine? like an aerio or reno engine? thank you
  6. big ed
    04-04-2014 08:30 AM - permalink
    big ed
    What does it take to get off my back...he has with me ever sense he couldn't tolerate me putting a locker in this 2wd. Surly you two can see that its that is so petty...she going to have the last word no matter what and she is the first one to tell somebody they don't know what there talking about. I don't know how the pecking order works on one of these forums but you must be able to understand why people get a little pissed off. You don't need to respond and I do see what a bad spot you mods are in but just saying!!!
  7. suzukivitarairl
    04-02-2014 03:56 PM - permalink
    suzukivitarairl
    Vin No. Sorry wrong post
  8. gcpdriver
    09-10-2013 01:07 PM - permalink
    gcpdriver
    I suspect that after a good start, when the thermostat opens and the hot coolant passes by the various sensors, the signals are sent to the ECM and then other signals are sent back to the various solenoid valves or to the Emission controls and then I get the problem..I also suspect that it is vacuum related due to the fact that I can put a good driving load on the car and it seems to work fine and develop good power... until I have to put the clutch in or slow and stop at a stop sign and then it goes back to an idle condition (ie. no strong vacuum, no high RPM) and it dies. I have noticed that the Vapor Canister does NOT have the Canister Purge solenoid downstream in the line...it is missing. And the owner before me did not replace the Catalytic Converter...it too is missing...however this is a '90 Tracker and it has no sensor down at the Catalytic Converter...according to the book.
  9. gcpdriver
    09-10-2013 01:06 PM - permalink
    gcpdriver
    gcpdriver
    Newbie

    Join Date: May 2013
    Posts: 19
    Gallery: 0

    90 Tracker Dies when Thermostat Opens - HELP - Who can solve the mystery?

    Hi Fordem, you helped me before and seemed to know right where to look ...maybe you or someone you know could help me with this problem. Thanks

    '90 Tracker, 8V, 5speed, Starts on 1st try every time, idle is perfect (1550 then drops to 800), BUT when thermostat opens (about 2.5-3min after start) then the idle gets rough, and if left in idle condition, the car will sputter and die. BUT If you drive out and put a load on the car and drive it consistently, you detect NO PROBLEM...until you come to a stop sign, and the car returns to idle...then it dies and will not start again until it cools to a closed thermostat condition (10-15min. later).
  10. Elite
    07-05-2013 03:16 AM - permalink
    Elite
    Hiya, I sa that you can get the colour code with the VIN, the code has been scratched off on the car.
    here is the VIN: VSEETV02CNA206781
    Thank you very much for your time.

About Me

  • About fordem
    Location
    Georgetown, Guyana
    Vehicle(s) That You Own
    1993 Swift, 1998 Grand Vitara, 2005 Grand Vitara
    Occupation
    IT Infrastructure Engineer
  • Signature
    98 - 1.8 Mitsubishi Pajero iO
    98 - 2.0 Suzuki Grand Vitara - SQ420
    05 - 2.0 Suzuki Grand Vitara - JB420
    15 - 2.4 Kia Sportage

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 02:05 PM
  • Join Date: 03-22-2009
  • Referrals: 2
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:07 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.