excessive static on am radio - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Technical > General Car Audio, Video and Electronics
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-10-2007, 06:19 PM   #1 (permalink)
 
Join Date: Oct 2007
Posts: 2
Gallery: 0
buttons is on a distinguished road
Default excessive static on am radio

I have heard several people all with the same issue in 2006 grand vitara model with excessive static on am radio when outside of any major urban area. also i am getting noise from the engine on am radio. the dealer replaced the stereo but it is still the same. wondering if any body has any thoughts as to how to make my listening experience any better
buttons is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-11-2007, 11:21 PM   #2 (permalink)
Veteran
 
Join Date: Nov 2007
Location: Portland, Oregon, USA.
Posts: 811
Gallery: 0
jim_naisium is on a distinguished road
Default

I have the 99 Esteem, same problem, buzz goes up and down with the engine speed, about the only thing you can do is put an RF choke on the power lead going into the radio. Check around at car stereo stores they should carry them.

But for the most part I never listen to the AM band anyway and stick with FM which doesn't have that problem.

What I do on long trips is load up my MP3 player with more music than I am going to need to get to where I'm going, and if I need it I have a USB port adapter that plugs into the cigarette lighter that I can use to recharge it with (MP3 player has internal batteries that recharge through the USB connector).

Last edited by jim_naisium; 11-11-2007 at 11:24 PM.
jim_naisium is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Technical > General Car Audio, Video and Electronics

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:07 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.