94 sidekick electrical problem - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Technical > General Car Audio, Video and Electronics
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-09-2015, 09:05 PM   #1 (permalink)
Member
 
silverzj's Avatar
 
Join Date: May 2015
Location: long island
Posts: 69
Gallery: 0
silverzj is on a distinguished road
Default 94 sidekick electrical problem

I have to be honest with you guys, I had to jump start the Suzuki the other day because its been dead. Now, it was getting dark and for some stupid reason, the negative terminal post clamp is red and the positive post has a black cap over it. I crossed the wires while jumping it. Other then what I just said, I have no other excuse other then stupidity for not really checking.

This is a project I picked up a few weeks ago. Since I wasn't able to really drive the car too much before I bought it, I don't know if these were issues to begin with or me crossing the wires caused it. I can say that when I crossed the wires that the main 60a fuse blew and I didn't think it would have gotten a chance to make it to the computer.

If someone can watch the video posted below that I shot of the few electrical problems and give some honest input, it would be great. I'd rather not assume its the computer right off the bat because it would be a loss of money to just buy one when not needed.


https://www.youtube.com/watch?v=AbHHmK3-3ks
__________________
94 Sidekick JLX 16v 1.6l -The Project
02 Subaru Impreza 2.5ts -The Daily
silverzj is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-09-2015, 09:10 PM   #2 (permalink)
Member
 
silverzj's Avatar
 
Join Date: May 2015
Location: long island
Posts: 69
Gallery: 0
silverzj is on a distinguished road
Default

I do have an update on this that may help with diagnosing it? Today when I got home from work, I unplugged the security system. All my troubles seemed to go away. No more rear defroster light and no more locks going off. I plugged the security system back in to see if my problems would come back. They didn't come back. Now, I'm thinking it was a freak thing and it was over with. I started pulling the wires for the spark plugs as I'm replacing them and when I pull the second cylinder wire, the alarm chirps and the locks go off. I go to check the brakes again and my problems are back. I unplugged the security system again and this time, my problems haven't gone away. I completely removed the security system to rule it out.

I'm in need of some guidance here.
__________________
94 Sidekick JLX 16v 1.6l -The Project
02 Subaru Impreza 2.5ts -The Daily
silverzj is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Technical > General Car Audio, Video and Electronics

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:18 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.