2007 swift 1.3 immobliser trouble please help. - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Technical > General Car Audio, Video and Electronics
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-14-2015, 05:08 PM   #1 (permalink)
Newbie
 
Join Date: Mar 2015
Posts: 2
Gallery: 0
Conrod95 is on a distinguished road
Default 2007 swift 1.3 immobliser trouble please help.

hi im new to this website, and looking for someone to help me with my car, i bought my swift not too long ago and it is all standard with no modifactions. the car was only supplied with one key, i understand there are 2 diffrent types of key mine is the lower spec key with the 2 buttons on it and it does not split apart as i understand that style is for keyless entry or stop/start functions. anyway the key was lost and i wasnt paying the fortune that suzuki dealers wanted as well as getting the car transported to them so i found and identical swift at a breakers yard and aquired a new ignition barrel, door lock, immobiliser ring, and the fuse box/immobiliser unit which is located on the far right underneath the dash board, after removing the door to gain entry to my car i proceeded to replace all my old usless locks with my near gear, now it is all fitted the immobilser warning light doesnt come on when i try to start it, i programmed the key to the car so the buttons on the fob work the central locking and i know the transponder in the key is being read by the ring as it does not activate the imobilser warning light. however the car turns over but does not fire. also i have noticed that when i turn the ignition on the battery warning light flashes as does the red airbag warning light (i assume the pattern of these flashing lights is an indication for an error code??) do i need to replace the engine ecu with the one from my donor car? (i am unsure if the immobiliser is also programmed into that ecu unit), i left the battery disconnected for a while (when i was fitting all the new parts which i assume would of reset the immobilser) apart from that i am really stuck do you know what i could try or anyone that i could speak to over the phone to help get my car going again. many thanks connor.
Conrod95 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-14-2015, 05:12 PM   #2 (permalink)
Guest
 
Join Date: Jun 2008
Location: The Kingdom of England
Posts: 5,299
Gallery: 5
Rhinoman is on a distinguished road
Default

You need the ECU as well. Did the part numbers on the fuse boxes match? it sounds like you have another issue other than the ECU and immo not matching.
Rhinoman is offline   Reply With Quote Quick reply to this message
Old 03-14-2015, 05:15 PM   #3 (permalink)
Newbie
 
Join Date: Mar 2015
Posts: 2
Gallery: 0
Conrod95 is on a distinguished road
Default

Yea i feared as much il have to go back for the ecu on monday and give it a go thanks for your help.
Conrod95 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Technical > General Car Audio, Video and Electronics

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:35 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.