2004 xl7 - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Marketplace > Classifieds - For Sale / Trade
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-16-2015, 08:26 AM   #1 (permalink)
Newbie
 
Join Date: Mar 2015
Posts: 2
Gallery: 0
GASilverBullet is on a distinguished road
Default 2004 xl7

Hey folks... New to the site, but I've enjoyed the knowledge I've read thus far. Anyway, I think I'm going to pass on my XL7 project and offer it to the masses.
It's a 2004 XL7 with 151K, 4x4, auto, power options, cloth seats, pearl white, decent tires, no rust, no major body damage, good glass and all gauges and electronics work.
It needs an oil pump or a motor... I'm not sure if an oil pump will fix the truck, or if there might be other problems. It turns over, but sounds "tight" for lack of a better word. I'm saying it needs a motor as a "worse case" possibility for any potential buyer. I'd like to get $1200.00 for it as a complete car. I did drive this car when I first got it and it shifted smooth, the transfer case works perfectly. I believe there are plenty of perfectly usable parts on this truck for only $1200.00! I planned on a motor, but I just don't have the expertise to make it a fast enough swap.. I can't tie up a garage spot right now. Please feel free to PM me for any information that's needed. I'll gladly send pics to whoever would like some. The truck is located in Athens, GA.
GASilverBullet is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-17-2015, 08:12 PM   #2 (permalink)
Newbie
 
Join Date: Mar 2015
Posts: 2
Gallery: 0
GASilverBullet is on a distinguished road
Default 2004 xl7

UPDATE:
I started the XL7 today.. I don't think there is any internal failures "yet" with the motor, and an oil pump should fix the problem. I didn't run it for more than a min or two as to not screw it up any further.
GASilverBullet is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Marketplace > Classifieds - For Sale / Trade

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:50 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.