Suzuki Forums: Suzuki Forum Site - View Single Post - Frustrated with the Toyota carb!
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
View Single Post
Old 08-29-2012, 10:44 PM   #5 (permalink)
BrendenV
Member
 
Join Date: Aug 2011
Posts: 47
Gallery: 0
BrendenV is on a distinguished road
Default

I was finally able to get it running right. All it took was a trained ear and someone who had some knowledge of carbs to fix it. Nowhere in the write up does it mention a throttle return spring but you will need one to get it to run right. What's weird is none of my vacuum lines are even pulling a vacuum at all.

I hooked up the carb right and plugged all lines. Follow the write up EXACTLY! you might as well print it and keep it under the hood. One thing I did differently though was port and polish the carb as well as the spacer. I didn't run it without porting it so i'm not sure if it made a difference.

I'm much happier now that it's running right and I can easily maintain the speed limit now!!! haha
BrendenV is offline   Reply With Quote
 
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:23 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.