Suzuki Forums: Suzuki Forum Site - View Single Post - Frustrated with the Toyota carb!
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
View Single Post
Old 08-23-2012, 07:39 PM   #1 (permalink)
BrendenV
Member
 
Join Date: Aug 2011
Posts: 47
Gallery: 0
BrendenV is on a distinguished road
Angry Frustrated with the Toyota carb!

So for the last 3 months I've been trying to get my 79 corolla carb installed and RUNNING RIGHT! I was able to follow acks write exactly...so I thought. I modified the spacer I plugged all vacuum ports and was able to fit the fuel line correctly. It starts right up when I pull the choke and drives just fine but when I slow down to a stop it stalls out. When I start it back up I have to continuously have to rev the engine. I've been messing with the adjustment screws and nothing seems to work. It idles high and idles low then goes back up then back down. That to me seems like a vacuum leak but I have everything plugged! The idle is so sporadic it's unsafe to drive. When I let off the gas it will idle ok for a few seconds then will just die like its got no fuel. Fuel lines are ok that's not the problem.

I know the people who have the yota carb love it and I wish I could too but it's keeping me from driving my Sami and I'm thinking of buying a stock carb and just putting that on.

Last edited by BrendenV; 08-23-2012 at 07:45 PM.
BrendenV is offline   Reply With Quote
 
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:16 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.