Problem with ECU (OBD) communication - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Swift and Geo Metro Forum > 2004+ Swift
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-01-2011, 07:15 AM   #1 (permalink)
Newbie
 
Join Date: Apr 2011
Posts: 5
Gallery: 0
ROLO is on a distinguished road
Default Problem with ECU (OBD) communication

I need help with my big problem
My car is Suzuki Swift 2001 (Mono Injector)
Engine G13BA
Bought in Israel
Made in Hungary
When I try to connect to ECU, using OBD adaptors (I have tried
1.ELM Scan tool 1.4
2.OBD adaptor made in Russia) and Lenovo Laptop computer with different kind of OBD software I get following massage "The device not found".
It only happens on my swift . The same equipment was used on several lately made cars of differnt brands with great success ,as well I tested the both adapter with HyperTerminal by receiving ASCI symbols while shortcutting certain pins in it, so my conclusion is :the problem probably with OBD protocol, configuration of ECU or connector.
I would be greatly appreciated to have some clue or information in order to solve the predicament.
Thanks
Roman
ROLO is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-08-2011, 02:51 PM   #2 (permalink)
Guest
 
Join Date: Jun 2008
Location: The Kingdom of England
Posts: 5,299
Gallery: 5
Rhinoman is on a distinguished road
Default

Its most likely not OBD2, which pins on the diagnostic connector are populated?
What was the Russian software that you tried?
Rhinoman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Swift and Geo Metro Forum > 2004+ Swift

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:37 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.