Issues with my 2011 Suzuki Swift 1.4 l auto gl. - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Swift and Geo Metro Forum > 2004+ Swift
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-30-2017, 04:57 AM   #1 (permalink)
Newbie
 
Sam1985's Avatar
 
Join Date: Mar 2017
Posts: 1
Gallery: 0
Sam1985 is on a distinguished road
Default Issues with my 2011 Suzuki Swift 1.4 l auto gl.

Hello everyone,

I have come to you knowledgeable people for advice in regards to by swift giving me a hard time for the past 6 months.

Its a problem that doesn't always occur, it comes and goes at random times.

My car starts as normal and drives well until i would get to a set of traffic lights, I will stop and it starts to idle differently, almost feels like its going to switch off but it doesn't.

Light goes green, my foot is on the accelerator but car doesnt move, it starts to shake and acts very choppy.

In a few seconds it drives as normal but accelerates a little too quickly.

I have visited my mechanics and he has changed the airflow sensor and ignition coils which didn't help the issue.

It has been an ongoing problem for some time know and I wish you guys can give me some advice please.

Much appreciate your feedback.
Sam1985 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-06-2017, 06:19 PM   #2 (permalink)
Full Member
 
Join Date: Jun 2015
Posts: 134
Gallery: 0
100 td is on a distinguished road
Default

Does this happen WITHOUT the air conditioner and fan ON?
__________________
GL Navigator Swift
100 td is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Swift and Geo Metro Forum > 2004+ Swift

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:04 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.