Problem with A/C Switch - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Sidekick, Escudo, Vitara & Geo Tracker Forum (1989-1998)
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Suzuki-Forums.com is the premier Suzuki Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-07-2013, 08:04 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2013
Location: Missouri
Posts: 18
Gallery: 0
JKtheSlacker is on a distinguished road
Default Problem with A/C Switch

Hi all, new member here. I bought The Deathtrap from my brother and his wife about a year and a half ago. I love my little Tracker, especially since it has working Air Conditioning (not a concern lately, but a big deal last summer!)

My question is this: When I first got the truck, the A/C switch inside the cab wasn't working. My brother ran a separate switch that taps into one of the connectors - I believe it may be where a relay is supposed to live, though I haven't looked at it in a while. Does this situation sound familiar to anyone, and does anyone know where I could get a replacement relay?
__________________
The Deathtrap - 1991 2 Door Geo Tracker, 3 Speed Auto with 4WD and Soft Top
JKtheSlacker is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-11-2013, 01:22 PM   #2 (permalink)
Newbie
 
Join Date: Apr 2011
Posts: 9
Gallery: 0
grandpaclint is on a distinguished road
Default

Quote:
Originally Posted by JKtheSlacker View Post
Hi all, new member here. I bought The Deathtrap from my brother and his wife about a year and a half ago. I love my little Tracker, especially since it has working Air Conditioning (not a concern lately, but a big deal last summer!)

My question is this: When I first got the truck, the A/C switch inside the cab wasn't working. My brother ran a separate switch that taps into one of the connectors - I believe it may be where a relay is supposed to live, though I haven't looked at it in a while. Does this situation sound familiar to anyone, and does anyone know where I could get a replacement relay?
I have the same problem with my 96 tracker 4x4 16 v 1.6 auto.
i have jumped the compressor and it works just fine,,cant seem to find the relay,
the little green light comes on when I press the switch, but no a/c

good luck to both of us
grandpaclint is offline   Reply With Quote Quick reply to this message
Old 01-11-2013, 01:28 PM   #3 (permalink)
Max
Moderator
 
Max's Avatar
 
Join Date: Aug 2006
Location: South Carolina, USA
Posts: 10,540
Gallery: 0
Max is on a distinguished road
Default

Try researching via this existing (similar problem) thread...

http://www.suzuki-forums.com/suzuki-...questions.html
__________________
'99 Grand Vitara JLX, 2.5L V-6, 4WD, 5 spd std, '00 "Limited" leather interior. OE center armrest, alarm, Fog lights & Sirius radio.
'53 Chevy 3100 Pick-up w/327 SB, TH400 trans w/78' Nova rear end.
'03 Honda Odyssey (Momma's ride)
'72 Chevy Nova. One owner, SB, A/C, power disc/drum & steering
.
Max is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Sidekick, Escudo, Vitara & Geo Tracker Forum (1989-1998)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:31 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.