Weber carb install experts..... - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Suzuki-Forums.com is the premier Suzuki Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-29-2010, 07:47 PM   #1 (permalink)
Newbie
 
Join Date: Feb 2009
Posts: 18
Gallery: 0
redbrand is on a distinguished road
Default Weber carb install experts.....

Have the old carb off and ready to install the new weber on wifes
88 Samauri. I have found the instructions that have came with it
pretty much suck the big one. I have some basic questions:

1. Does any body have a web link to some ones site that have nice
details about a Weber Sammy install??? I have searched the net and come
up with nothing on that and surprised some one hasn't detailed this info
out on Samauri Weber install.........

2. DO I have to fab up some sort of mounting braket for the exsisting
throttle cable braket and the modulation EGR valve. I see the throttle cable
needs to approach the Weber from a different direction and wonder what to
mount the exsisting cable braket too ??

3. Do I even need the Modulation EGR valve and use the port out of the weber right to the ERG valve. Damn instuctions doesn't mention any thing about that.

4. Do I need the old OEM carb plate that was between the carb and
intake manafold. I presume by looking at the instuctions this old peice
is not needed. Just want to make sure before I put the carb on.

5. Any pics of your install would grealty help me - pics say a thousand words.

Thanks a bunch in advance !!!
__________________
RedBrand

1996 JX SideKick, 4x4, 2 door/soft top, 16valve SOHC 1.6L Engine ,87K org miles.
redbrand is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-29-2010, 10:28 PM   #2 (permalink)
Veteran
 
Join Date: Jan 2008
Location: San Diego, CA
Posts: 1,230
Gallery: 0
Baratacus is on a distinguished road
Default

what weber do you have that uses the EGR? If you search for the type of weber carb that you have you might have better luck,

heres an install guide for the 34 DCOE
http://www.racetep.com/weber/INS-WK601-34.pdf

The throttle cable should have come with your kit. It uses the existing cable and piece of "L" shaped pipe at the end of your throttle cable
Baratacus is offline   Reply With Quote Quick reply to this message
Old 03-30-2010, 07:14 AM   #3 (permalink)
Newbie
 
Join Date: Feb 2009
Posts: 18
Gallery: 0
redbrand is on a distinguished road
Default

After digging around last night I did find out that the throttle cable bracket is
missing - figures. I did find where to order it for $20 and it is a L shaped braket. I still trying to find out about the EGR valve. I also found some real good tech info. about a line out of the Weber back to the vent canister to bleed off gas from the carb to keep it from stalling/dead spots- due to the factory fuel pump supplying too much pressure. That was pretty interesting and will try that out - so simple to do.

A word to caution to all who buy a Weber to install on a Sammy. The directions that come with are - well to put it in normal terms -just plain A suck! Alot of reference to things you don't have to do or it doesn't really tell you what you can get rid of. My directions say to use the exsistin hard ware for the damn throttle cable - wrong there is no way in heck you can make that happen.

Also the factory nuts holding down the OEM carb are a mother to get loose and hard for any wrench to get to them. It took me over 30 minutes just to break those loose. On some I had to use a hammer with a small point chisal
to break them loose since I couldn't get my open end wrench to break them loose. None the less I got them all off.
__________________
RedBrand

1996 JX SideKick, 4x4, 2 door/soft top, 16valve SOHC 1.6L Engine ,87K org miles.
redbrand is offline   Reply With Quote Quick reply to this message
Old 03-30-2010, 08:20 AM   #4 (permalink)
Veteran
 
Join Date: Jan 2008
Location: San Diego, CA
Posts: 1,230
Gallery: 0
Baratacus is on a distinguished road
Default

well on the upside the adapter plate you install has allen head bolts. As for the throttle cable, you should be using the existing cable and mounting tube. It should bolt directly to the throttle bracket that was missing from your kit. It you got it second hand you're out of luck, but if you bought it from a dealer or distributor, then they should cover the costs of missing parts. Don't run the overflow back to the vent canister. That's for fuel vapor only and should never have wet enter it. The fuel return line to the tank is what you need to tap into.
Baratacus is offline   Reply With Quote Quick reply to this message
Old 03-30-2010, 09:04 AM   #5 (permalink)
Member
 
Join Date: Mar 2010
Location: Lenoir, NC
Posts: 28
Gallery: 0
Daletec is on a distinguished road
Default

Also, keep in mind that the factory fuel pump works great with Webers, the fuel return from the pump lets excess return to the tank. I did not modify the float bowl with a vent or anything else and it works great.
Daletec is offline   Reply With Quote Quick reply to this message
Old 03-31-2010, 08:14 AM   #6 (permalink)
Newbie
 
Join Date: Feb 2009
Posts: 18
Gallery: 0
redbrand is on a distinguished road
Default

Finally fired it up last night. Took a short drive but have some more work to do.
I did remove all vacuum devices except what went to/out of the Weber.
I did not neet the EGR valve - capped it off.

We have been wanting a Weber for more power and the little sammy had a rough idle issue at low idle speeds with the OEM carb. So I that just tipped
us to buy and put the Weber on - knowing there still could be the chance of
the rough low idle still present.
After firing up the Weber last night and taking a quick trip up thr road - I still have the low rough idle - just like before with the OEM carb. You can here the miss even in the exhaust sound. Higher RPMs it sounds normal and runs great.
So - onto the rought idle issue before really tuning in the new Weber. But the bottom line is the Weber is on and all seems well with it - so far.

Just have to find my low rough idle problem. Yes - nearly all electrical items
were replaced before the Weber was installed -but not all, have the items inside the distributor that might be the problem. BUt moving to the other more simple items first. I am bound and determined to find this damn low idle miss - has me on a mission.

Last night it drove me to several colds ones
__________________
RedBrand

1996 JX SideKick, 4x4, 2 door/soft top, 16valve SOHC 1.6L Engine ,87K org miles.
redbrand is offline   Reply With Quote Quick reply to this message
Old 03-31-2010, 11:26 AM   #7 (permalink)
Senior
 
Join Date: Nov 2008
Posts: 188
Gallery: 0
gasjr4wd is on a distinguished road
Default

pressure test.
you need to see what valve is burnt. (hint)
what condition is the cam in?
gasjr4wd is offline   Reply With Quote Quick reply to this message
Old 03-31-2010, 03:31 PM   #8 (permalink)
Newbie
 
Join Date: Feb 2009
Posts: 18
Gallery: 0
redbrand is on a distinguished road
Default

That is what my thinking is at this point - burnt valve or valve related.
Just by the way it sounds coming out of the exhaust.

Timing light indicates steady fire on all cyclinders - during the rough idle or mis.

I will turn it over tonight so see what my pressures are in each cyc and report back in the morning. Hopefully I have the right size for the spark plug
hole on the sammy.

ALL WAYS something at my house - sure the lawn mower is ready to crap out next -
__________________
RedBrand

1996 JX SideKick, 4x4, 2 door/soft top, 16valve SOHC 1.6L Engine ,87K org miles.
redbrand is offline   Reply With Quote Quick reply to this message
Old 04-03-2010, 04:14 PM   #9 (permalink)
Full Member
 
Join Date: Jul 2009
Posts: 117
Gallery: 5
87samurai_dunn is on a distinguished road
Default

another problem ive been noticing is spark plugs are coming with cracked insulators, check the plugs when you take em out, also check for any vacuum leaks
87samurai_dunn is offline   Reply With Quote Quick reply to this message
Old 04-04-2010, 03:33 PM   #10 (permalink)
Newbie
 
Join Date: Feb 2009
Posts: 18
Gallery: 0
redbrand is on a distinguished road
Default

I have been able to "tune" the new Weber to minmize my engine miss at low idle - but the low rough, spitter idle is now the less still there.

Compression test:
Cyc. #1 155 psi
Cyc. #2 159 psi
Cyc. #3 153 psi
Cyc. #5 150 psi

Over all not bad on compression... I did remove the valve cover and did find a cam bearing cap bolt complete loose. Retighten and moved on. Sidekicks
are famous for that happing. But nothing looks are feels out of the norm concerning valve springs. I am going to check the valve clearences.

My next question - ANY BODY HAVE THE HOT AND COLD VALVE CLEARENCES ?? I do not have a FS manual and my sticker under my hood is not readable.

Thanks guys...... onward I march to trying to solves this damn rough idle !!
__________________
RedBrand

1996 JX SideKick, 4x4, 2 door/soft top, 16valve SOHC 1.6L Engine ,87K org miles.
redbrand is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:11 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.