Pulling on acceleration/deceleration - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-20-2017, 12:07 PM   #1 (permalink)
Newbie
 
Join Date: Mar 2017
Posts: 1
Gallery: 0
Slow is on a distinguished road
Default Pulling on acceleration/deceleration

Hello, I've been searching your site but can't find my answer.

My samurai is spua on 3" trail gear springs with lift shackles, on 32's. A few days ago, I removed a Calmini shackle reversal setup and installed new spring bushings and lift shackles in the front, and shackles in the back that are about 3/4" longer that what was on it. I also installed caster shims on the front axle with new u bolts. After all this, I test drove it several miles at highway speed and it drove great. No issues whatsoever.

The following day I replace the knuckle ball wiper seal with the Trail Gear "Trail Safe" wiper seal kit. This involved removing kingpin bearings, which I inspected, re-packed and reinstalled with the same shims. The hub was stiffer to turn with the new seal on, but everything seemed to go together fine. Knuckle has no play when I finished.

After that, I drove it and had to fight to keep it on the road at highway speed. When accelerating it pulls moderately to the left, on deceleration it dives hard to the right. This makes sense with the geometry of the drag link and suspension movement but not to that extreme. What could possibly cause a difference from before and after I did that knuckle wiper seal?

Similar to this thread but there is no definitive answer.
http://www.suzuki-forums.com/suzuki-...feeling-2.html
Slow is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:53 AM.



Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.