Heating A/C fan noise - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Equator
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Suzuki-Forums.com is the premier Suzuki Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-07-2013, 10:17 AM   #1 (permalink)
Newbie
 
Join Date: Jun 2012
Location: Atlanta, Georgia
Posts: 9
Gallery: 0
ATLOffroad is on a distinguished road
Default Heating A/C fan noise

Around Christmas time I hopped into my Equator turned on the heat and I began hearing a ticking noise coming from the fan. A day later it disappeared, but then again the ticking noise came back a few days later. I've looked at the fan in the footwell of the passenger side and the noise sounds like it is coming from the motor. I'm thinking a bearing has gone bad inside the motor. I could be wrong though.

Any thoughts on how to fix the fan motor? It looks easily assessable. If I can do it myself, where is the best parts place to shop for a new fan?

Thanks for the help.
ATLOffroad is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-14-2013, 11:15 AM   #2 (permalink)
Newbie
 
Join Date: Jan 2013
Posts: 1
Gallery: 0
driver3 is on a distinguished road
Default

Not the same car, but try this.

I had the same problem with my Isuzu - when running AC/Heat, sometimes condensation builds up in the system. If it was below freezing the day you had this issue, the condensation can ice the fan blades causing the out of balance sound. What you do is run the heat at full blast until the fan blades would thaw - noise gone.

Might want to try that... Just a thought.
driver3 is offline   Reply With Quote Quick reply to this message
Old 01-19-2013, 04:44 PM   #3 (permalink)
Newbie
 
Join Date: Jun 2012
Location: Atlanta, Georgia
Posts: 9
Gallery: 0
ATLOffroad is on a distinguished road
Default

I fixed the ticking noise. I did some research on the Frontier Forum website and found out the heating and A/C blower seems to break quite often. I used this thread:

How to Replace or Check the Blower Motor (ticking or buzzing when the air vent is on) - Nissan Frontier / Navara Forum

I ordered a new blower for just $42 and replaced it in about an hour and a half. Problem solved and no more loud ticking.
ATLOffroad is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Equator

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:01 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.