Oil Light Reset - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 2G (2007+) XL7
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Suzuki-Forums.com is the premier Suzuki Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-17-2010, 08:34 PM   #1 (permalink)
Newbie
 
Join Date: Feb 2010
Location: Stockbridge ,Ga
Posts: 10
Gallery: 0
radicalrusxl7 is on a distinguished road
Smile Oil Light Reset

Yes how do you reset the oil light sensor after oil change?
radicalrusxl7 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-17-2010, 09:42 PM   #2 (permalink)
Full Member
 
Join Date: Dec 2009
Posts: 138
Gallery: 0
northeastXL7 is on a distinguished road
Default

Use the center button of the DIC and scroll through until you get to the oil life remaining screen. Then push and hold the checkmark button until it resets to 100%. 2007 MY do not always reset the first time. Repeat the procedure until it resets-this may take several tries. There is not a fix to correct this glitch. 08-09 MY work the first try every time. Also I do not recommend following the OLM percentage-it simply runs the oil too long in this engine and will lead to sludge.
northeastXL7 is offline   Reply With Quote Quick reply to this message
Old 02-17-2010, 10:41 PM   #3 (permalink)
Veteran
 
Join Date: Sep 2008
Posts: 1,376
Gallery: 0
Jeff L. is on a distinguished road
Default

I'll add in case you were wondering - the procedure in the owners manual for 2007 is WRONG. Use what the above poster has said, works.
Jeff L. is offline   Reply With Quote Quick reply to this message
Old 02-18-2010, 11:03 PM   #4 (permalink)
Newbie
 
Join Date: Feb 2010
Location: Stockbridge ,Ga
Posts: 10
Gallery: 0
radicalrusxl7 is on a distinguished road
Unhappy

ok i did what you said like 55 times and it did not work
radicalrusxl7 is offline   Reply With Quote Quick reply to this message
Old 02-19-2010, 12:22 AM   #5 (permalink)
Full Member
 
Join Date: Dec 2009
Posts: 138
Gallery: 0
northeastXL7 is on a distinguished road
Default

I'm assuming you have an '07 then. Keep tryinh it-it will eventually work. You are probably seeing the percentage blink momentarily while you're doing this-when it finally takes it you will see it blink and then it will display 100%. I know it's frustrating but GM will probably never give us a fix for this. The only other way to do it is to hook up the Tech2 and manually reset it w/ the scan tool.
northeastXL7 is offline   Reply With Quote Quick reply to this message
Old 02-21-2010, 03:37 PM   #6 (permalink)
Senior
 
Goaterguy's Avatar
 
Join Date: Nov 2007
Location: Greenville, SC
Posts: 365
Gallery: 0
Goaterguy is on a distinguished road
Default

Yes, set DIC to oil life, press and check mark button until the % flashes and release, if it doesn't go back to 100% press again until it flashes and release. Keep repeating until you get it.

Mine takes about five times but mostly it resets at the first time.
__________________
2005 GTO PBM M6
2007 Suzuki XL7 Luxury AWD
2006 Aprilia Scarabeo 500 GT ABS+
2007 Roadrunner Classic iscooter "Pinky"
2006 B&S 3.5 hp lawnmower
Goaterguy is offline   Reply With Quote Quick reply to this message
Old 02-26-2010, 04:45 PM   #7 (permalink)
Member
 
Join Date: Dec 2006
Posts: 46
Gallery: 0
guxu is on a distinguished road
Default

Faint, I just did that (07 XL7) over the weekend. I followed the owners manual and of course it did not work. I was wondering if that was because I changed the oil before the "Change oil soon" light was on.

I pressed check mark button too and did see the % flashing. Then, somehow, while pushing the gas (following the owners manual) and pressing check mark button, the % suddenly reset.
guxu is offline   Reply With Quote Quick reply to this message
Old 02-26-2010, 08:49 PM   #8 (permalink)
Newbie
 
Join Date: Feb 2010
Location: Stockbridge ,Ga
Posts: 10
Gallery: 0
radicalrusxl7 is on a distinguished road
Default

Quote:
Originally Posted by guxu View Post
Faint, I just did that (07 XL7) over the weekend. I followed the owners manual and of course it did not work. I was wondering if that was because I changed the oil before the "Change oil soon" light was on.

I pressed check mark button too and did see the % flashing. Then, somehow, while pushing the gas (following the owners manual) and pressing check mark button, the % suddenly reset.
Yea it finally worked for me
radicalrusxl7 is offline   Reply With Quote Quick reply to this message
Old 08-29-2010, 01:25 PM   #9 (permalink)
Member
 
Join Date: May 2009
Posts: 29
Gallery: 0
Silver 2008 XL7 is on a distinguished road
Smile oil change re-set oil change light to 100%

I reset oil change light by turnung key to on and pumoing break pedel five times. Oil percent came up to 100%.

AL
Silver 2008 XL7 is offline   Reply With Quote Quick reply to this message
Old 02-04-2012, 03:44 PM   #10 (permalink)
Newbie
 
Join Date: Feb 2012
Posts: 1
Gallery: 0
lolo7 is on a distinguished road
Thumbs up Finally worked

Had to do it like 15 times. It finally did reset. I also tried the break, but that did not work for me. Thanks!
lolo7 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 2G (2007+) XL7

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:18 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.