How long do I have? - Page 2 - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 1G (2001-2006) XL-7
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Suzuki-Forums.com is the premier Suzuki Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-09-2012, 06:07 AM   #11 (permalink)
Super Moderator
 
XL7Limited's Avatar
 
Join Date: Nov 2004
Location: South Jersey
Posts: 3,406
Gallery: 0
XL7Limited is an unknown quantity at this point
Default

Quote:
Originally Posted by Techneck View Post
It is an auto. I was thinking about draining what I can out and replacing this weekend. Has anyone tried putting Lucas Trans Fix in these trucks?
The auto trannys are brutally strong on our trucks. I doubt its making any noise. Its actually rare to see one that needs a rebuild. I would drain and refill and try the Lucas additive..
XL7Limited is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-17-2012, 09:31 AM   #12 (permalink)
Full Member
 
ngrome's Avatar
 
Join Date: Feb 2009
Location: Chicago, IL
Posts: 149
Gallery: 6
ngrome is on a distinguished road
Default

Mine experienced the same thing in the cold when we moved up north. Found out all it took was adding motor oil, at least for me, because it was low. On a related note, mine just turned over 203,000 miles, should the timing chain have been changed at some point? 200K crept up on us like that, fluids changed religiously, brakes etc., just haven't done the timing chain, which I know is a big costly job. Seems to be running strong still though, knock on wood...
__________________
Paul
2004 XL7 Limited
Now at 230K miles!
ngrome is offline   Reply With Quote Quick reply to this message
Old 11-17-2012, 09:30 PM   #13 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 7,598
Gallery: 0
fordem is on a distinguished road
Default

There's no recommended replacement interval for the timing chains, if it's not rattling at start up, just leave them alone.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara
fordem is offline   Reply With Quote Quick reply to this message
Old 11-20-2012, 04:09 PM   #14 (permalink)
Newbie
 
Join Date: Nov 2012
Location: Alabama
Posts: 7
Gallery: 0
Techneck is on a distinguished road
Default

Ok I worked on this truck this weekend. By now I am pretty sure the two sounds are unrelated. The more prevalent rattle seems almost nonexistent after putting fresh 5-30 oil in with a Suzuki filter. It is only there on really cold mornings and last just for a few seconds now.
I put it on blocks so i could put it in gear while I track down the source of the other sound. So I put her in gear and nothing no sound Increasing the rpms made no difference what so ever. Let the truck down off blocks and as soon as it is put in gear and start rolling there is the sound.
My next step is to have my wife drive the truck back and forth up the drive as I hang out the passenger to listen to pin down the sound. It is defiantly coming from under the front of the truck.
Back up it goes this time with a buddy of mine and some brake torquing we replicated the sound. When the tranny flexed there was the rattle.
After looking around on this forum about the Y pipe shield rattle I figured that might be it. After running a couple of self tapping screws though the shield allowing them putting pressure on the pipe. I drop her down and did the road test. No rattle . I know the screws wont last but they gave me the answer I needed.
So has anyone just removed this shield? It don't seem like it would really hurt anything. Like I said before this truck only makes short trips.

BTW I did change out some of the transmission fluid I figure what the heck I was already under there.
Techneck is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 1G (2001-2006) XL-7

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:54 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.