Grand vitara slowly lost power, stalled and wont't start - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 1G (1999-2005) Vitara & Grand Vitara
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Suzuki-Forums.com is the premier Suzuki Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-24-2013, 05:53 PM   #1 (permalink)
Newbie
 
Join Date: Feb 2012
Posts: 3
Gallery: 0
silverivyraven is on a distinguished road
Unhappy Grand vitara slowly lost power, stalled and wont't start

hi everyone...
I have a 2000 Suzuki grand vitara v6 that my husband says driving when it suddenly began to lose power and the stalled out. it now ill not start. We replaced the fuel filter, checked the fuel pump as well as spark plugs...


Please help me figure out how to get my car to start so I don't have to get it towed again.
silverivyraven is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-24-2013, 06:16 PM   #2 (permalink)
Max
Moderator
 
Max's Avatar
 
Join Date: Aug 2006
Location: South Carolina, USA
Posts: 11,037
Gallery: 0
Max is on a distinguished road
Default

Will it run on "starting fluid"? That will narrow down a no spark or no fuel problem. Have the computer scanned for error codes too.

That's a troubleshooting start.
__________________
'99 Grand Vitara JLX, 2.5L V-6, 4WD, 5 spd std, '00 "Limited" leather interior.
'53 Chevy 3100 Pick-up w/327 SB, TH400 trans w/78' Nova rear end.
'03 Honda Odyssey (Momma's ride)
'72 Chevy Nova. One owner, SB, A/C, power disc/drum & steering
.
Max is online now   Reply With Quote Quick reply to this message
Old 07-26-2013, 05:46 PM   #3 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 4,879
Gallery: 0
aquanaut20 is on a distinguished road
Default

Quote:
it suddenly began to lose power and the stalled out
This generally indicated an issue on the fuel delivery side, (electrical is usually abrupt).. Test the fuel pressure with a gauge, then test the Fuel pressure regulator... Philip
__________________
92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 200k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Old 07-27-2013, 03:58 PM   #4 (permalink)
Newbie
 
Join Date: Feb 2012
Posts: 3
Gallery: 0
silverivyraven is on a distinguished road
Default Checked

We pulled the plug near the engine and it is getting fuel. There are relays under the dash next to the fuse box.... What do these do? I thought the fuel pump relay was under the hood with the main?
silverivyraven is offline   Reply With Quote Quick reply to this message
Old 07-27-2013, 04:51 PM   #5 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 4,879
Gallery: 0
aquanaut20 is on a distinguished road
Default

Quote:
Originally Posted by silverivyraven View Post
We pulled the plug near the engine and it is getting fuel. There are relays under the dash next to the fuse box.... What do these do? I thought the fuel pump relay was under the hood with the main?
This is a FI engine, not carburated... it requires fuel pressure to spec, flowing fuel does not prove that.... USE a gauge.... Philip
__________________
92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 200k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Old 08-06-2013, 12:11 PM   #6 (permalink)
Member
 
Join Date: Apr 2013
Posts: 94
Gallery: 0
AdamBecker is on a distinguished road
Default

How slowly did it loose power? Like it slowly lost power in a day or over a month??
AdamBecker is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 1G (1999-2005) Vitara & Grand Vitara

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:42 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.