Help Hard Shifting? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 1G (1999-2005) Vitara & Grand Vitara
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Suzuki-Forums.com is the premier Suzuki Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-27-2011, 02:20 PM   #1 (permalink)
Member
 
Join Date: Jan 2011
Posts: 32
Gallery: 0
Bigman is on a distinguished road
Default Help Hard Shifting?

Hey guys, I got my new motor in, it sounds great and runs strong but now my 02 v6 auto Tracker shifts hard from park to drive or reverse. It also makes a noise on the down shift at about 15mph. Once moving it shift harder but not as hard like from park. Where is the kick-down cable and what should i use when i change my tranny fluid? I originally thought it was the computer relearning but its been 2 days and 40 miles. Thanks for the help.
Bigman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-27-2011, 11:25 PM   #2 (permalink)
Member
 
Join Date: Jan 2011
Posts: 32
Gallery: 0
Bigman is on a distinguished road
Default

Update, I found the kick-down cable. When i pull the cable it springs back so i dont think thats the problem.
Bigman is offline   Reply With Quote Quick reply to this message
Old 03-28-2011, 05:55 AM   #3 (permalink)
Max
Moderator
 
Max's Avatar
 
Join Date: Aug 2006
Location: South Carolina, USA
Posts: 10,995
Gallery: 0
Max is on a distinguished road
Default

Big! Same trans that was in there prior to the engine swap?

If so, I'd double check all of the interconnecting tranny wires / plugs for cleanliness and contact.
__________________
'99 Grand Vitara JLX, 2.5L V-6, 4WD, 5 spd std, '00 "Limited" leather interior.
'53 Chevy 3100 Pick-up w/327 SB, TH400 trans w/78' Nova rear end.
'03 Honda Odyssey (Momma's ride)
'72 Chevy Nova. One owner, SB, A/C, power disc/drum & steering
.
Max is online now   Reply With Quote Quick reply to this message
Old 03-28-2011, 07:59 AM   #4 (permalink)
Member
 
Join Date: Jan 2011
Posts: 32
Gallery: 0
Bigman is on a distinguished road
Default

Same Tranny, i will check wiring.
Bigman is offline   Reply With Quote Quick reply to this message
Old 03-28-2011, 08:34 AM   #5 (permalink)
Max
Moderator
 
Max's Avatar
 
Join Date: Aug 2006
Location: South Carolina, USA
Posts: 10,995
Gallery: 0
Max is on a distinguished road
Default

After that, I'd look for and dump any codes off a computer scan. Then it wouldn't hurt to disconnect the battery for a few to re-boot the ECU. It does have an ECU to TRANS interface built into it.
__________________
'99 Grand Vitara JLX, 2.5L V-6, 4WD, 5 spd std, '00 "Limited" leather interior.
'53 Chevy 3100 Pick-up w/327 SB, TH400 trans w/78' Nova rear end.
'03 Honda Odyssey (Momma's ride)
'72 Chevy Nova. One owner, SB, A/C, power disc/drum & steering
.
Max is online now   Reply With Quote Quick reply to this message
Old 03-28-2011, 09:29 AM   #6 (permalink)
Member
 
Join Date: Jan 2011
Posts: 32
Gallery: 0
Bigman is on a distinguished road
Default

As far as the codes wouldnt i have a check engine light or some warning on the cluster? I dont think im pulling any codes. I might just change the fluid but whats the chance of this happening right at the time a new engine gets put in.
Bigman is offline   Reply With Quote Quick reply to this message
Old 03-28-2011, 09:39 AM   #7 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 4,854
Gallery: 0
aquanaut20 is on a distinguished road
Default

Did you have any issue inserting the Torque converter??
__________________
92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 200k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Old 03-28-2011, 10:04 AM   #8 (permalink)
Max
Moderator
 
Max's Avatar
 
Join Date: Aug 2006
Location: South Carolina, USA
Posts: 10,995
Gallery: 0
Max is on a distinguished road
Default

Quote:
As far as the codes wouldnt i have a check engine light or some warning on the cluster?
It depends on the code / fault. SOME codes trigger the CEL right away, while others require several repetitive triggers. They would be on the scan regardless though, either in active or history.

Quote:
whats the chance of this happening right at the time a new engine gets put in
It points to SOMETHING not reattached or adjusted properly, given that all was presumably well from the get-go. But there IS always a coincidence failure against you too.
__________________
'99 Grand Vitara JLX, 2.5L V-6, 4WD, 5 spd std, '00 "Limited" leather interior.
'53 Chevy 3100 Pick-up w/327 SB, TH400 trans w/78' Nova rear end.
'03 Honda Odyssey (Momma's ride)
'72 Chevy Nova. One owner, SB, A/C, power disc/drum & steering
.
Max is online now   Reply With Quote Quick reply to this message
Old 03-23-2013, 10:59 AM   #9 (permalink)
Newbie
 
Join Date: Mar 2013
Location: Virgin Islands
Posts: 12
Gallery: 0
suzuki boyz is on a distinguished road
Default

I am having the same problem that I cannot figure out. I changed the transmission fluid, transfer case fluid, and front+rear diff fluid. i know the post is a bit old but did you ever solve this particular problem?
suzuki boyz is offline   Reply With Quote Quick reply to this message
Old 03-23-2013, 11:09 AM   #10 (permalink)
Max
Moderator
 
Max's Avatar
 
Join Date: Aug 2006
Location: South Carolina, USA
Posts: 10,995
Gallery: 0
Max is on a distinguished road
Default

The original post discussed after engine swap problems. You'd be better off starting your own thread with all of the pertaining info included.
__________________
'99 Grand Vitara JLX, 2.5L V-6, 4WD, 5 spd std, '00 "Limited" leather interior.
'53 Chevy 3100 Pick-up w/327 SB, TH400 trans w/78' Nova rear end.
'03 Honda Odyssey (Momma's ride)
'72 Chevy Nova. One owner, SB, A/C, power disc/drum & steering
.
Max is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 1G (1999-2005) Vitara & Grand Vitara

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:14 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.