Burning smell and smoke from under hood - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 1G (1999-2005) Vitara & Grand Vitara
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance

Suzuki-Forums.com is the premier Suzuki Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-25-2009, 02:18 PM   #1 (permalink)
Newbie
 
Join Date: Aug 2009
Posts: 10
Gallery: 4
a-whiteway is on a distinguished road
Exclamation Burning smell and smoke from under hood

A few days ago i had my dealer put a new water pump in my 04 GV (second pump in 4 months). While they had it apart they put in a new timing chain tensioner because some models have a history of them going weak. When i got it back from the dealer i smelled a burning smell and thought it's likely just some chemicals and fluids that got on some parts during the repairs burning off or my brakes. The other night i was backing into a parking spot and when i went from R to P the engine died and the dash lit up like a christmas tree. I turned it on again with no problem but when i went through all the gears while parked the engine sputtered when i went from P-R-N-D and at one point the check oil light almost came on. I took it for another drive today and the service engine soon light came on. I had a look under the hood and there was light smoke coming from the drivers side and i could see kind of fluid under the oil filter. Does anyone have an idea whats going on. It could be something as simple as the oil filter isn't on tight enough or something much more serious.
a-whiteway is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-25-2009, 02:41 PM   #2 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 4,986
Gallery: 0
aquanaut20 is on a distinguished road
Default

Smoke and smell never good, if you suspect the filter leaking, let cool and try tightening by hand, if that does not fix leak, remove filter(check for double gasket), clean seating surface, oil gasket and reset or replace filter.

If the CEL is illuminated, scan for codes and let us know...

If it related to work performed by dealer let them rectify the problem to maintain any warranty fallback.
__________________
92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 200k
aquanaut20 is online now   Reply With Quote Quick reply to this message
Old 10-25-2009, 02:55 PM   #3 (permalink)
Senior
 
Join Date: May 2009
Posts: 198
Gallery: 0
x_sgs_x is on a distinguished road
Default

This is a pretty bad issue. I would call the dealership and have them fix it
x_sgs_x is offline   Reply With Quote Quick reply to this message
Old 10-25-2009, 11:06 PM   #4 (permalink)
Senior
 
tmcalavy's Avatar
 
Join Date: Oct 2005
Posts: 368
Gallery: 0
tmcalavy
Default

Ditto...call the dealer, the tow and fix should be their baby.
__________________
Say Hello to my leetle friend!
tmcalavy is offline   Reply With Quote Quick reply to this message
Old 10-30-2009, 07:57 PM   #5 (permalink)
Newbie
 
Join Date: Aug 2009
Posts: 10
Gallery: 4
a-whiteway is on a distinguished road
Default

turned out to be that the gasket on the valve cover plate wasn't reset right
a-whiteway is offline   Reply With Quote Quick reply to this message
Old 10-31-2009, 08:24 AM   #6 (permalink)
Max
Moderator
 
Max's Avatar
 
Join Date: Aug 2006
Location: South Carolina, USA
Posts: 11,297
Gallery: 0
Max is on a distinguished road
Default

That makes sense on the leak / smell / smoke issue but not the quitting and CEL light. Watch it close and return it at the slightest issue from here on out.
__________________
'99 Grand Vitara JLX, 2.5L V-6, 4WD, 5 spd std, '00 "Limited" leather interior.
'53 Chevy 3100 Pick-up w/327 SB, TH400 trans w/78' Nova rear end.
'03 Honda Odyssey (Momma's ride)
'72 Chevy Nova. One owner, SB, A/C, power disc/drum & steering
.
Max is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Vitara, Grand Vitara & XL-7 Forum (1999+) > 1G (1999-2005) Vitara & Grand Vitara

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:15 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.